Broken links on Services section on the Home page

edited November 2014 in HealthCentre
The "Read more" links on the Services description on the Home page are broken links result in error 404. See Capture11.png & Capture12.jpg.

(this issue was issue #5 on http://webriti.com/support/discussion/838/formating-issues-with-the-services-section#Item_14 and it still not solved)

Please provide a solution.

Thanks,
Capture11.png
1403 x 1372 - 1M
Capture12.JPG
1408 x 1377 - 165K

Comments

  • Kindly repalce the index-services.php file with the orignal one. I have seen that somethig is wrong with the html structure.


    Here is your read more link formatting which is not correct

    <p>Elite Healthcare! One of the most caring and dedicated home health care providers in Northern, New Jersey. Elite Healthcare offers a full range of home care services for pediatric, adult and geriatric clients.
    &lt;p&gt;&lt;a href=" http:="" elite-healthcare.net="" services="" home-health-aide-services="" "="">Read more <span class="fa fa-arrow-circle-right hc_service_reamore_icon"></span></a></p>


  • My index-services.php is the original file I have. That file was not changed not in the parent or the child themes. If this file is incorrect please send me the correct one.

    Thanks,
  • See if you havent change this file than there absolutely no need to update this.

    Kindly share the screenshot what you have in the service post type screen.

    Thanks
    Priyanshu
  • Prianshu, I am not sure which screenshoot you want to see.
  • Share me the sanpshot of the view from where you have added the service link on the front page
  • I am still confused as to what you looking for. The services were entered through the Services menu entries as it show in Capture15.jpg attached.
    Capture15.JPG
    1399 x 1347 - 137K
  • hi

    I checked home page services at our end. It is working fine here. I am attaching a index-service.txt file here. Please replace your code with it and let me know abut the result.

    Thanks

    Vijay
  • Find the attached file index-service.php
    index-service.txt
    3K
  • edited November 2014
    Vijay, there is no change it behaves the same.
    When you click on "Read more" of the 1st service on Home page as it shown in Capture11.png it takes you to the link as it shown in Capture16.jpg

    instead of

    http://elite-healthcare.net/services/home-health-aide-services/

    Try it yourself at http://elite-healthcare.net/

    Please provide a fix.
    Capture11.png
    1403 x 1372 - 1M
    Capture16.JPG
    1408 x 938 - 103K
  • hi

    Could you please confirm what you set in URL when you give detail of various field in featured service.
    Please check it with your resultant URL. Still you have facing problem then attach index-service.php.

    We will check the localhost with your code.

    Thanks
    Vijay
  • Vijay, I am not sure what you are asking but as you can see from Capture17.jpg the links to the service are set correctly. Also attached is the index-service.txt which is basically the file that you provided me.

    Please provide solution ASAP.

    Thanks,
    Capture17.JPG
    1409 x 1357 - 249K
    index-service.txt
    3K
  • Vijay, I am awaiting for solution from you.
  • hi

    Every thing is fine at our end. Please share your login detail at my gmail. [email protected]
    Hope your issue will be resolved.

    Thanks
    Vijay

  • edited November 2014
    Also you should be check few parameters.

    1. Replace the line no. 59 in custom_post_type.php with 'rewrite' => array('slug' => $GLOBALS['slug_service']), 
    2. Set the service slug using option panel as you want.
    3. Set the Permalink in service description as your target url.

    Thanks
    Vijay
  • Vijay, this is exactly the line #59 that I already have in my custom-post-type.php see attached.

    Please no more delay. Please fix the problem.

    Thank you,
    custom-post-type.txt
    6K
  • hi

    Please confirm to me about line no. 59 in custom_post_type.php.
    Reply ASAP with the code of this perticular line. I am waiting for your reply because I am working with your access.

    Thanks
  • I match your code, its perfect.

    Please wait for few minute, I am engage with solving your issue.

    Thanks
  • Hi

    I got some conclusion, when you left blank your service slug in option panel and add new services than it is working.
    But with your customize slug name, it encounter an error '404'.

    Please remove your published services and add it again. And active your plugin one by one.

    Let me know for any confusion.


    Thaks
    Vijay

  • Vijay I do not understand you. the service slug is not empty. it is "services".
  • Vijay, we went through this story already few days ago.
    The services slug must be "services" for this website not the default "healthcenter_service".
    If you leave the slug empty it defaults to "healthcenter_service".
    This is not an acceptable solution.
  • just replace

     'rewrite' => array('slug' => $GLOBALS['slug_service']), 

    with

    'rewrite' => array('slug' =>'service'),

    and left blank service_slug field in option panel.

    Then add new service and check.

    Thanks
  • Vijay, I am getting tired of you not providing a working solution.

    1. I deleted the Home Health Aide Services and reentered it.
    2. I changed the slug code in custom-post-type.php to 'services'
    3. I left the services slug blank in options.

    The problem on the Home page for Home Heath Aide Service is still the same.
    In addition to that when I edit a service and select not to open the link in a new Window/tab it always forces it to open in new tab. These pages should not open in new window/tab.

    Vijay please get to work and provide a working solution now!
  • edited November 2014
    Vijay I found what causes the problem.
    The link on the Home page for the service Read more gets broken when there is the More tag in the service text after the first paragraph.
  • Everything is working now.
    1. I removed the More tag from the services text
    2. I reverted back to the original custom-post-type.php
    3. I set the services slug in Options to 'services'

    You can close this ticket
This discussion has been closed.