How do I fix the URL's of individual services linked from your Services page?

edited November 2014 in HealthCentre
Your theme automatically inserted "healthcentre-service" in the individual services URL's instead of "services". See Capture8.png attached.

The URL format for each individual service needs to be:
http://[domain-name]/services/[service-name] or in our case it should look like:

http://elite-healthcare.net/services/home-health-aide-services/ and not
http://elite-healthcare.net/healthcenter_service/home-health-aide-services/

Please provide a solution to fix this problem.

Thanks,
Capture8.png
1413 x 1386 - 1M

Comments

  • edited November 2014
    hi

    To fix permalink as you want, please open custom-post-type.php

    and replace
     'rewrite' => array('slug' => $GLOBALS['slug_service']),
    with
    'rewrite' => array('slug' => 'services'),

    Now confirm which setting you are using for permalink.
    To confirm it go to Deshboard >> settings >> permalink
    there you found different mode of permalink.

    First set it to default(if not) and run your website, now change it to post name and check again your website permalink whether it showing correct permalink or show 404 error.

    If your issue did not resolve after make these updation then please attach service-template.php and single-healthcenter_service.php file and custom-post-type.php.

    Thanks
    Vijay
  • Vijay,

    Isn't your solution for
    and replace
    'rewrite' => array('slug' => $GLOBALS['slug_service']),
    with
    'rewrite' => array('slug' => 'services'),

    the same as replacing the Services Slug in Appearance >> Option Panel >> Post Type Slug from
    healthcenter_services to services?

    If it is the same than I tried that and it still results in 404 errors.

    My permalink is set correctly to /%postname%/



    single-healthcenter_service.txt
    1K
    service-template.txt
    3K
    custom-post-type.txt
    6K
  • edited November 2014
    hi

    you can also change service_slug name from option panel, after changing slug name set permalink to default then again set it to post name.
    Without changes in permalink setting it will show 404 error.

    Just try it and reply to me whether it is working or not.

    Thanks
    Vijay
  • Ok the links are working now but I still have the formatting issue that all the text is pushed to the right like in the attached Capture9.png.

    Please provide a fix for the formatting.
    Capture9.png
    1413 x 1386 - 1M
  • You can close this ticket. Thank you.
This discussion has been closed.