Formating issues with the Services section

edited November 2014 in HealthCentre
I found 4 problems with the implementation of the Services section in the Health Centre theme. Please provide fixes as follows:

1. The individual service descriptions text on the Home page need to be left justified. See Capture6.png attached.

2. The individual service descriptions text on the Services page is missing the "Read more...". See Capture7.png attached.

3. Your theme automatically inserted "healthcentre-service" in the individual services URL's instead of "services". See Capture8.png attached.

4. The text on individual service pages is pushed to the right like a sidebar. The text need to be formatted and wrapped around the featured image like you fix the About-Us page (example: http://elite-healthcare.net/about-us/). See Capture9.png.

Please provide these fixes to the Services section ASAP as it delays development of client website.

Thanks,
Capture6.png
1403 x 1386 - 1M
Capture7.png
1404 x 1378 - 936K
Capture8.png
1413 x 1386 - 1M
Capture9.png
1413 x 1386 - 1M

Comments

  • edited November 2014
    hi

    To fix problem no. 1, go to dashboard >> appearance >> option panel:
    In home page -> quick start setting find custom CSS and paste the below describe code.

    .hc_service_area p
    {
     text-align: left;
    }


    To fix problem no. 2, Copy service-template.php from parent theme and paste in child theme package, if you are following the child theme concept.
    Otherwise find service-template.php in core theme package.

    <p><?php echo get_service_template_excerpt(); ?></p>

    and replace it with

    <p><?php echo get_service_template_excerpt(); ?></p>
    <p><a href="#"><?php _e('Read more','health'); ?> <span class="fa fa-arrow-circle-right hc_service_reamore_icon"></span></a></p>


    and find the below lines of code in same template

    <p><?php _e('Lorem ipsum dolor sit amet, consectetur Unlimited ColorsCras pulvin, mauris at so mauris at lectus lectus.','health'); ?></p>


    and replace it with

    <p><?php _e('Lorem ipsum dolor sit amet, consectetur Unlimited ColorsCras pulvin, mauris at so mauris at lectus lectus.','health'); ?></p>
    <p><a href="#"><?php _e('Read more','health'); ?> <span class="fa fa-arrow-circle-right hc_service_reamore_icon"></span></a></p>


    Thanks
    Vijay
     
  • edited November 2014
    hi

    To fix problem no. 4, you need to make following changes:
    1. If using parent/core theme then
    Find single-healthcenter_service.php and replace its code with below attached text file.

    2. If using child theme then
    Create single-healthcenter_service.php in child theme package and insert the code of below attached text file in it.

    Thanks
    Vijay
    single-healthcenter_service.txt
    1K
  • edited November 2014
    hii

    Regarding problem no.3, your services template are managing in two aspect.
    First,Number of services are shows through service-template.php.
    Second, If you browse any one service from services, then it manages through single-healthcenter_service.php.
    That's the reson for change in permalink of services.
    For first case your permalink should be sitename/service
    and for second case it should be sitename/healthcenter_service/firsr-service.

    Note: Single-filename.php is dedicated for single post (CPT) in Custom Post Type

    Let me know if any doubt in our reply.

    Thanks
    Vijay

  • Vijay, here are the results of your solutions:

    1. Fixed. Thank you.

    2. The "Read more" links are in wrong color and they do not function. They do not go to the corresponding service pages. See Capture10.png

    3. You explain how your them work now you did not provide a solution. I understand that the http://elite-healthcare.net/services/ page should act as the index or table of content for the various services. Clicking on an individual service on that page or on the home page should take the user to an individual service description page that has a permalink of http://elite-healthcare/services/[servicename]. The term "healthcentre-service" should never appear in a permalink. Please provide a fix.

    4. Your solution did not solve the problem irrespective if I change single-healthcenter_service.php in the child or the parent theme. take a look at http://elite-healthcare.net/healthcenter_service/home-health-aide-services/ and please provide a solution.

    5. A new related problem. The "Read more" links on the Services description on the Home page are broken links result in error 404. See Capture11.png & Capture12.jpg. Please provide a solution.

    Thanks,

    Capture10.png
    1405 x 1377 - 840K
    Capture11.png
    1403 x 1372 - 1M
    Capture12.JPG
    1408 x 1377 - 165K
  • hii

    Really sorry for your inconvenience.

    For problem no 2, you need to changes in service-template.php
    Find below lines of code

    <p><?php echo get_service_template_excerpt(); ?></p>
    <p><a href="#"><?php _e('Read more','health'); ?> <span class="fa fa-arrow-circle-right hc_service_reamore_icon"></span></a></p>

    and replace with

    <p><a href="<?php echo $meta_service_link; ?>" <?php  if(get_post_meta( get_the_ID(),'meta_service_target', true )) { echo "target='_blank'"; }  ?> ><?php _e('Read more','health'); ?> <span class="fa fa-arrow-circle-right hc_service_reamore_icon"></span></a></p>

    And to change color of read more bullton, type below line of code in custom css

    .media-body p a {
    color: green;
    }
    replace green color text with your desire color.

    Any update for your issue no. 4. i.e mention in capture9.png

    Thanks
    Vijay



  • edited November 2014

  • Please explain in detail about your services permalink issue. So we can reach at depth of it and provide you best solution.

    And you should raise a separate ticket. It helps for both, you and our team for batter analysis of the problem as well as deliver a best solution with fast response.

    Hope you will cooperate us.

    Thanks
    Vijay 
  • edited November 2014
    Vijay, while your latest solution for issue #2 solved the link and color problems, it appear that now the service description blurb between the title and the Read more complete disappeared. See Capture13.png and compare it to Capture7.png from my original message.

    Items 3, 4, & 5 are still not solve. Please provide solutions.

    Regarding item #3 the URL format for each individual service needs to be:
    http://[domain-name]/services/[services-name] or in our case it should look like:

    http://elite-healthcare.net/services/home-health-aide-services/ and not
    http://elite-healthcare.net/healthcenter_service/home-health-aide-services/

    Thanks,
    Capture13.png
    1402 x 1385 - 887K
  • edited November 2014
    Vijay, I solved issue #2.

    You left one line out in your instructions.
  • I am still awaiting for solutions to problems 3, 4, & 5.
  • hi

    Your problem no.1 & 2 has been solved. And you raise separate ticket for remaining problems.
    So let me know for close this ticket.

    Thanks
    Vijay
  • Vijay,
    1 & 2 are solved.
    3 is now on separate tickets.
    4 & 5 are not solved.

    You need to solve 4 & 5 before you can close the ticket.

    Please provide a solution ASAP as you delaying development of client website.

    Thanks
  • #3 is fixed.
    4 & 5 still open. Please provide solution.
  • hi

    I am getting confuse with lot of issues in same ticket. If your major problems are solved then let me know for close this ticket and raise separate tickets for remaining issues from beginning.

    Thanks
    Vijay 
  • you can close this. Issue 4 & 5 are now in separate tickets.
This discussion has been closed.