Button for Leave a reply doesn't work

seems, the button for Leave a reply doesn't work, at least is not clickable, as attached.
could you please kindly check it out?

and,
in another screenshot, I am not sure if the text "No Comments" is relevant to your theme. if it's relevant, can I know how to remove it or resize it? thanks.
Steven
ButtonLeaveAreplyDoesn'tWork.png
175K
assistanceforTextResize.png
281K
Tagged:

Comments

  • the link for the page from which I am talking about is
  • Hi, @steven_lidi

    It happens because of using comment plugin. It overwrites some class of the comment section. However, you get overcome this issue:

    Install Simple Custom CSS and JS plugin & Add JS Code from below:

    jQuery(function($){
    $('.dpr-wrap').attr("id","respond");
    });

    For the second: just paste the custom CSS in your custom CSS box of the theme:

    /*no comment: display*/
    .dpr-discu-main-loop-wrap > h3{
    text-align: center;
    font-size:20px;
    margin-left: 20px;
    }
    /*no comment: display*/

    Let me know did it work!

    Thanks
  • is the Simple Custom CSS and JS plugin a same thing to Snippets plugin?

    I did as you told,
    but there is following issue coming up now, as the attached screen shot, you may see that Submit button is hidden by the sticky menus.

    is there any possibility to tackle this issue?

    thanks very much, @imraz
     I understand you may be probably going extra miles to help me out here.
    I do appreciate it.

    and
    ReplySubmitButtonHiddenBehindtheStickyMenus.png
    159K
  • Hi, @steven_lidi

    To add the top/bottom position of the comment box, just need toAdd JS Code another as given below:

    jQuery(document).ready(function ($) {
                    $('a').on('click', function (e) {
                        // e.preventDefault();

                        var target = this.hash,
                                $target = $(target);
                        $('html, body').stop().animate({
                            'scrollTop': $target.offset().top - 400
                        }, 900, 'swing', function () {
                        });
                        return false;
                    });
                });

    * change 400 to more if want to shift more down the comment box from the top of the screen.

    Let me know did it work!

    Thanks
  • unfortunately, it doesn't work. but I reset the setting for the plugin myStickymenu, currently, t he
     sticky menu doesn't cover up the button submit to reply, just like the attached. I am ok with this now, unless you come up with better idea?~
    by the way, do I need to delete JS codes you gave above, but I failed to find the added codes to delete.
    currentViewofReplytoSummit.png
    127K
  • edited October 2018
    I have tested the above JS code and it's working fine at our end. However, if you want you can deactivate the JS like as shown in this screenshot

    Thanks
  • thank you very much. 
  • I temporarily deactivate it for future possible usage.
  • Hi, @steven_lidi

    Deactivate temporarily the above all my given JS, and just add a new one and try it, this will give you a better experience. On click, the page now directly goes to your comment box from the home page( previously it shows a page that does not scroll directly to the comment box)

    Just check this JS after pasting from this LINK

    Let me know if it works!

    Thanks
  • thanks for your further support, however, it doesn't wok at my end.
  • Glad to help you!

    If you like should I debug why not my code is working at your end, you can share me your wp-login details on my email address:-   [email protected]

    Thanks for contacting us :)
This discussion has been closed.