Blog Page Fixed but Blog Insert on Home Page Doesn't Show "More"

Hello - I inserted the <!--more--> tag into my blog posts and it fixed the blog page so that it only shows the first few sentences.  This is great!
Here is a photo: MtZOq2m.png

But when I go to the Recent Blog section of the home page it still shows the whole long article, and doesn't show the "more" button that I want. 
Here is a photo: vgkWV36.png

Please advise if there is any way to make the home page Blog section show the "more" button.  Thanks!

Comments

  • Hello 
    Thanks for contacting to us . 
    Our home page blog section   show read  more button of more tag . 

    Let me know did you made any kind of changes inside the index-blog.php file . 

    Kindly tell me so that we can assist you better . 

    Thanks 
  • Hello Akhilesh, I didn't make any changes to the index-blog.php file

    Lines 49 to 54 of the index-blog.php has code that handles 'Read More' but it doesn't work for my blog posts

    ///
    <div class="entry-header">
    <h4 class="entry-title"><a href="<?php the_permalink(); ?>"><?php the_title();?></a></h4>
    </div>
    <div class="entry-content">
    <p><?php the_content(__('Read More','busiprof')); ?></p>
    </div>
  • Also, my blog posts don't have anything special in the formatting they look like this:

    ///
    <p style="text-align: left;"><em>Text about the blog post goes here, it's italic and align left but no other formatting changes</em></p>
    <!--more-->

    <hr />
  • Hi 
    Issue resolve via email . 
    It was a plugin conflict  . 

    Thanks 
  • Yes Akhilesh was very nice and actually logged in to my account to identify and fix my problem.

    Thanks so much!
  • Hi 
    Thanks for your compliment dear . 
    Look forward see you again at webriti. 

    Fee free to ask us for any confusion . 

    Thanks 
This discussion has been closed.