Contact form - not sending to admin email address

edited May 2014 in HealthCentre
Hi, 

I have a problem with the contact form in the Contact-Us page. When I submit any form, the message should be sent to the 'admin_email', but that's not happening. The message goes nowhere... :(

Any help with this issue? I need to have it working urgently. My client launches the website on Monday.

Many thanks in advance.

Comments

  • Hi 


    You can also use easy smtp mail plugin

    Thanks
    Priyanshu
  • Thanks, Priyanshu, but it's still not working :(

    I don't use my gmail account, but an email account hosted by another company. I filled correctly all the fields, but the submit button is not sending anything.

    Can you please give me any solution?

    Many thanks.
  • edited May 2014
    Just to add... I tried with SSL turned ON and OFF, and neither option worked. I contacted my hosting and the confirmed that the server wasn't getting any email. I've also tried with a gmail email, but didn't work either. 
  • Which mailserver your are using and also your hosting provider.


  • My hosting provider is dinahosting. My mail is associated to my own domain. Do you need the name of my domain or the SMTP host?
  • yes if possible both
  • My domain is 'signup-ele.com' and my SMTP host is:

    with SSL "on": signup-ele-com.correoseguro.dinaserver.com 
    with SSL "off": mail.signup-ele.com
  • Which smtp plugin you are using
  • Webriti SMTP plugin
  • If possible provide me the temporary access over email at themes[at]webriti[dot]com
  • edited May 2014
    Sure, check your inbox and please let me know if you got my email.
  • check your smtp port with hosting provider
  • It's 465 for SSL on and 25 for SSL off
  • will get back on this after 12 hours. its already very late according to IST
  • edited May 2014
    Ok, thank you very much. We need to fix this as soon as possible. The web should be tomorrow launched. 
    Shall I keep your temporary access?
  • Hi 

    I have also tried with wp smtp mail plugin . Your SMTP settings is not correct.

    Do one thing just check the test mail utility in wp smtp mail plugin(Settings>Email) and show the debbuging output to your hosting provider.

    Key Errors are 
    1. "SMTP Error: Could not authenticate."
    2. SMTP Error: Could not connect to SMTP host.
    Also check your details once again, I mean your username,password,port and host.

    Thanks
    Priyanshu
  • Hi, I've checked all my details and I've changes SSL by TLS encryption, since my hosting provider uses that one. It gives me now a different error... I will as my hosting provider but I am not sure wether they can deal with this issue... 

    I'll come back to you in a while, when I have an answer from them.

    Is it necessary to have the TSL or SSL encryption "on"?

    Thank you.
  • edited May 2014
    Actually that's totally depends on the Mail Server Hosting .
  • edited May 2014
    Ok, they've checked and it's now working. But it's sending the emails to both the account I have specified and the admin email. Is that the way it should work?

    Many thanks for your help!
  • Any suggestions they have given.
This discussion has been closed.