contact page - captcha

I'd like to add a captcha code of some sort to the form on the Contact page. How would I do this?
Tagged:

Comments

  • edited January 2016
    Hi  @pumportal

    lets do step by step.

    1. download google captcha plugin from 
    here
    2 activate it.
    3. go to BWS plugins menu and go to Google captcha setting tab
    4 create site key and secret key and enter in related text box.
    5.save it.

    6. go to in your theme directory>> contact-us.php 

    7. open contact-us.php go to line number 65 and copy past the following code below  the line .

    <?php if( function_exists( 'gglcptch_display' ) ) { echo gglcptch_display(); } ; ?>

    8. save contact-us.php file 

    let me know this work for you

    Thanks
    Akhilesh
  • I'm pasting it under line number 65, but nothing is changing. I'm not sure I have the correct line 65. Can you please specify exactly what line of code it should be pasted under? Thanks.
  • Hey @pumportal

    let me know you configure 

    Google Captcha Settings

    settings 

    cause its working well on our end. share your site url

    Thanks
    Abhishek
  • I entered the site key and secret key and it's configured for version 1. Between what lines of code in contact.php should I paste the google captcha line? I don't think I put it in the right place.
  • edited March 2018
    Hey @pumportal,

    Sorry for delay response.

    paste google captcha code before this line approximate line number 65 

    <button class="hc_btn" type="submit" name="contact_submit" id="contact_submit"><?php _e('Send Message','health'); ?></button> 

     
    Thanks
    Abhishek
  • Hey @pumportal,

    Any update here ?

    Thanks
    Abhishek
  • It still doesn't seem to be working. :/ Attached is what my contact.php looks like.
    contactphp.txt
    7K
  • Hey @pumportal


    its working fine on our end if possible share your site admin detail on my email so we can fixed it on your end 

    Thanks
    Abhishek

  • My mistake! In the captcha settings, I had the captcha hidden for administrators so I couldn't see it. It IS working. Thank you. You can close this ticket now.
This discussion has been closed.