The monthly archive category in blogs does not work

Hi,

The monthly archives links for blogs on the side
bar does not work. If I try to open a blog written in a particular month, it
shows all the blogs written rather than showing the blogs written only in that
month. 

For example: I tried to read the blog written in July-2015, it showed those blogs and all the other blogs as well.

This seems to be a bug, so please suggest a solution.

Thanks!

Comments

  • Hi

    Its working perfect  at our end . 

    Let me know did you made any kind of changes in archive.php file (located in your theme folder ) .


    Thanks 
    Akhilesh

  • Hi Akhilesh,

    No! I have not done any changes in archive.php file.
    Please check the "Perspectives" page on veravizion.com and click on the "monthly archives posts" on the right side bar to check the issue that we are facing.

    Thanks!
  • Hi 

    1 Replace the code of archive.php  with the code of archive.txt (which is given below in the attachment ).

    Then let me know . 


    Thanks 
    archive.txt
    4K
  • Hi Akhilesh,

    I think I have found out the problem:

    The "archives" link work well with the default permalink structue. but it does not seem to work with the "www.website.com/postname" permalink structure.

    What could be the problem?

  • BTW, no change even after updating the latest code of archive.txt provided by you.

  • Hi Akhilesh,

    Any updates on this please?

    I am struggling with this issue as my readers are not able to check blogs monthwise.
  • Have you checked with the TwentyFifteen WordPress Theme.
  • ?? Nope.

    As mentioned earlier, I strongly suspect that the problem is because of the "www.website.com/postname" permalink structure... It is working fine with the default permalink structure on my localhost.
  • Hi

    If you find the same issue after activating 2015 theme than something is fishy with WordPress.

    I will ask my team mates to study more on this.

    Will see what best we can do for you.

    Thanks
    Priyanshu
  • Ok Priyanshu.

    Please check this out and let me know as soon as you find out the solution.

    Look forward to hearing from you soon. Thanks!
  • Hello Priyanshu,

    We had parked this query 3 months back. Have you got an answer to this query? for the website visitors, they are unable to view blog for a particular month.

    I am summarising the original query again here:
    The monthly archives links for blogs on the side bar does not work. If I try to open a blog written in a particular month, it
    shows all the blogs written rather than showing the blogs written only in that month. 

    For example: I tried to read the blog written in July-2015, it showed those blogs and all the other blogs as well.

    This seems to be a bug, so please suggest a solution.
  • Hi,

    Any updates please?

    Thanks!
  • Guys,

    This has been pending since a long long time now... This is really a problem for my blog.
    Need a response please.


  • Hey @veraqual

    Sorry for delay response.

    we all ready short out this issue kindly update your theme. 

    download new version from your member login area.

    Thanks
    Abhishek 


  • Abhishek,

    I have always had problems logging in my member login area.

    Kindly share the download link with me from where I can download the theme.

    Thanks!
  • kindly send the login details you are using on my email id themes[at]webriti[dot]com

    I think you are the one who asked to change the userid. may be that would be the problem.

    Thanks
    Priyanshu 
  • Priyanshu,

    yes, that's me :)
    just sent you email.

    Thanks for your help!

Sign In or Register to comment.